5 abr. 2011

Debian 6.0.1 [Update]

La primer actualización de la versión Squeeze.
Acá les dejo los Cambios:


=========================================
Sat, 19 Mar 2011 - Debian 6.0.1 released
=========================================
apt-dater (0.8.4-4+squeeze1) stable-proposed-updates; urgency=medium

  * Fix apt-dater-host.config, to not mess up with boolean values and integers.
    Closes: #611968


apt-setup (1:0.53+squeeze2) squeeze; urgency=low

  * Upload to drop .git from source tarball

apt-setup (1:0.53+squeeze1) stable; urgency=low

  * If no network mirror was selected during install, add a (commented-out)
    entry pointing at ftp.debian.org, together with a comment explaining why
    the entry is commented out and that it should be updated to use a relevant
    mirror.  The comment is not translated, but this is still preferable to
    the previous behaviour of creating clearly broken entries under such
    circumstances which users then re-enabled.  (Closes: #613910)


asterisk (1:1.6.2.9-2+squeeze1) stable-security; urgency=high

  * AST-2011-001/CVE-2011-0495: Stack buffer overflow in SIP channel driver
    (Closes: #610487)


avahi (0.6.27-2+squeeze1) stable-security; urgency=high

  * debian/patches/03_read_null_udp_packets.patch
    - Read NULL UDP packets else we end up in an infinite loop using 100% CPU
      and DoS of Avahi. (Closes: #614785, Fixes: CVE-2011-1002)
  * Urgency high for the security fix.


base-files (6.0squeeze1) stable; urgency=low

  * Changed /etc/debian_version to 6.0.1, for Debian 6.0.1 point release.


cdebconf (0.153+squeeze2) squeeze; urgency=low

  * No-changes upload to get rid of the .git directory in the source package.

cdebconf (0.153+squeeze1) squeeze; urgency=low

  [ Joey Hess ]
  * Support window managed use of the gtk frontend, by asking
    the WM to fullscreen d-i, thus leaving room for decorations etc.
    Closes: #605401 (Patch from Ben Armstrong)


cgiirc (0.5.9-3squeeze1) stable-security; urgency=high

  * Non-maintainer upload by The Security Team.
  * Fixed XSS flaw in handling clients who have Javascript disabled.
    [CVE-2011-0050]

cgiirc (0.5.9-3lenny3) oldstable-security; urgency=low

  * Non-maintainer upload by the security team.
  * Fix XSS attack for non-javascript using clients.
    [CVE-2011-0050].


chromium-browser (6.0.472.63~r59945-5+squeeze4) stable-security; urgency=low

  * Fixed CVE-2011-0779: does not properly handle a missing key in an extension,
    which allows remote attackers to cause a denial of service
   (application crash) via a crafted extension.
  * Fixed CVE-2011-1290: Integer overflow in style elements
  * Removed mips from arch to avoid flood of given-back build log

chromium-browser (6.0.472.63~r59945-5+squeeze3) stable-security; urgency=low

  * Backported security patches from stable:
    - [54262] High URL bar spoof with history interaction. Credit to Jordi
      Chancel.
    - [63732] High Crash with javascript dialogs. Credit to Sergey Radchenko.
    - [68263] High Stylesheet node stale pointer. Credit to Sergey Glazunov.
    - [69640] Medium Out-of-bounds read in text searching. Credit to Kostya
      Serebryany of the Chromium development community
    - [64-bit Linux only] [70376] Medium Out-of-bounds read in pickle
      deserialization. Credit to Evgeniy Stepanov of the Chromium development
      community.
    - [71114] High Stale node in table child handling. Credit to Martin Barbella
    - [71115] High Stale pointer in table rendering. Credit to Martin Barbella.
    - [71855] High Integer overflow in textarea handling. Credit to miaubiz.
    - [71960] Medium Out-of-bounds read in WebGL. Credit to Google Chrome
      Security Team (Inferno).
    - [72134] High Memory corruption in SVG fonts. Credit to Andreas Kling.
    - [69628] High Memory corruption with counter nodes. Credit to Martin
      Barbella.
    - [70027] High Stale node in box layout. Credit to Martin Barbella.
    - [70336] Medium Cross-origin error message leak with workers.
      Credit to Daniel Divricean.
    - [72028] High Stale pointer in table painting. Credit to Martin Barbella.
    - [73746] High Stale pointer with SVG cursors. Credit to Sergey Glazunov.

chromium-browser (6.0.472.63~r59945-5+squeeze2) stable-security; urgency=high

  * Backported security patches from stable:
    - High Stale pointer in animation event handling. Credit to Rik Cabanier.
    - High Stale pointer with anonymous block handling. Credit to Martin
      Barbella.
    - Medium Out-of-bounds read in plug-in handling. Credit to Bill Budge of
      Google.
    - Medium Possible failure to terminate process on out-of-memory condition.
      Credit to David Warren of CERT/CC.


clamav (0.97+dfsg-2~squeeze1) stable; urgency=medium

  [ Michael Tautschnig ]
  * Proper suite name.
  * More tidy up: new upstream release also fixed problems with
    ExtendedDetectionInfo (upstream bb#2409, closes: #617262).
  * Upload intended for squeeze-updates (fixes security issues, urgency bumped
    to medium).

clamav (0.97+dfsg-1) UNRELEASED; urgency=low

  [ Alberto Wu ]
  * New upstream release

  [ Stephen Gran ]
  * General tidy up


clive (2.2.13-5+squeeze1) stable; urgency=low

  * Adapt for youtube.com changes. (Closes: #616575)
    + new patch: 0001-Youtube-Fix-video-ID-parsing-10.patch
  * debian/rules: Set CLIVE_CACHE when running tests to avoid build failure
    when $HOME is not writable.


cmake (2.8.2+dfsg.1-0+squeeze1) stable-proposed-updates; urgency=low

  * Regenerate original tarball removing files provided under proprietary
    licence. (Closes: #614390) They were not actually used. Mention removed
    files in the debian/copyright.


colo-installer (1.17+squeeze1) stable-proposed-updates; urgency=low

  [ Martin Michlmayr ]
  * Make sure to put "hda" into the CoLo config file instead of "sda"
    since CoLo only knows about the former.  Closes: #614839


console-setup (1.68+squeeze2) squeeze; urgency=low

  * No-changes upload to get rid of the .git directory in the source package.

console-setup (1.68+squeeze1) squeeze; urgency=low

  [ Samuel Thibault ]
  * Use bg, ch, se instead of bg(bds), ch(de), se(basic), as those are not in
    xorg.xml any more (closes: #610843).


cryptsetup (2:1.1.3-4squeeze2) stable-proposed-updates; urgency=low

  * fix changelog for cryptsetup 2:1.1.3-4squeeze1.

cryptsetup (2:1.1.3-4squeeze1) stable-proposed-updates; urgency=low

  * NOT RELEASED YET
  * install cryptkeyctl initramfs hook, needed for keyctl keyscript in
    initramfs, thanks to Maik Zumstrull (closes: #610750)
  * fix luksformat script to invoke usage() with --help. (closes: #612947)
  * luksformat: invoke udevadm settle between mkfs.vfat and luksClose, to
    prevent possible race conditions. This is a workaround. (closes: #601886)


dajaxice (0.1.5-1squeeze1) stable-security; urgency=low

  * debian/patches/fix_csrf_verification: (Closes: #614787)
    - Fix bug related to CSRF verification on Django


dbconfig-common (1.8.46+squeeze.0) stable; urgency=low

  * Fix version sorting logic bug on upgrade files in postinst.
    Thanks to Ghislain Mokolomboka <mghislain@dvidea.com> (Closes: #611820)


debian-installer (20110106+squeeze1) squeeze; urgency=low

  [ Jurij Smakov ]
  * Add pata-modules to cdrom config for sparc and sparc64.
    Closes: #610906.

  [ Martin Michlmayr ]
  * qnap-flash-debian: recognize QNAP TS-x12 devices.
  * lspro-config-debian: Exit if the firmware version cannot be
    determined.  Thanks John Bytheway.  Closes: #609476


debian-installer-netboot-images (20110106.squeeze1) squeeze; urgency=low

  [ Daniel Baumann ]
  * Adding tftpd-hpa to suggests, this is the tftp server that is covered in
    the installer manual (Closes: #597116).

  [ Otavio Salvador ]
  * Update to 20110106+squeeze1 version.

  [ Julien Cristau ]
  * Fetch images from squeeze-proposed-updates.
  * We need to fetch 20110106+squeeze1, but can't be versioned that way
    because that would be lower than 20110106.b1.  So hack up debian/rules to
    turn . into +.
  * Drop debian-installer-6.0-netboot-hppa.

debian-installer-netboot-images (20110106.b1) unstable; urgency=low

  * Update to 20110106+b1 images.
  * Add support to handle binNMUs.

debian-installer-netboot-images (20101127) unstable; urgency=low

  * Update to 20101127 images.

debian-installer-netboot-images (20101020) unstable; urgency=low

  * Update to 20101020 images.


debian-reference (2.46) stable; urgency=low

  * Updated Portguese translation by Américo Monteiro.
  * Fixed s/--get-selection/--get-selections/ etc. Closes: #612435
  * Reflected introduction of squeeze-updates suite which replaced
    Debian Volatile Service. Closes: #614224
  * Fixed URL for Debian Mirror Checker site. Closes: #614253


debootstrap (1.0.26+squeeze1) stable-proposed-updates; urgency=low

  [ Miguel Figueiredo ]
  * Fix bug and typo on --private-key
    Patch by Jonathan Klee.
  * Fix for ar usage, thanks to Guillem Jover. Closes: #598729


deluge (1.2.3+git20110209.8c36830-0squeeze1) stable; urgency=low

  * Imported Upstream version 1.2.3+git20110209.8c36830
    - Upstream commit 8c36830 backported from the 1.3.x release:
      "fix hang on quit". (Closes: #602613)


desktop-base (6.0.5squeeze1) stable; urgency=low

  * debian/plymouth:
    - include patch by adris to fix dual screen setups.         closes: #613249


devscripts (2.10.69+squeeze1) stable; urgency=low

  * bts: Accept the "wheezy" and "wheezy-ignore" tags.
  * debchange:
    + Set Squeeze as the default backports target.
    + Recognize "lenny-backports-squeeze" and "squeeze-backports"
      distributions.
    + Remove "etch-backports" and "etch-volatile" distributions.


eclipse (3.5.2-6squeeze2) stable; urgency=low

  * Backported patch for CVE-2010-4647. (Closes: #611849)
    - Fixes XSS in help browser application.


exuberant-ctags (1:5.8-3squeeze1) stable; urgency=low

  * Apply patch from Ben Spencer to use memmove rather than strcpy on
    overlapping strings (closes: #594185).


finish-install (2.28squeeze1) stable-proposed-updates; urgency=low

  [ Aurelien Jarno ]
  * Recognize /dev/duart* as a serial console.


ganeti (2.1.6-1+squeeze1) stable; urgency=low

  * Fix "Wrong permissions for /var/lock after 'gnt-node add'" (applied
    patch fixing octal mode usage) (Closes: #613648)


gdm3 (2.30.5-6squeeze1) stable; urgency=low

  [ Josselin Mouette ]
  * gdm3.init: chown the configuration to Debian-gdm, to avoid umask
    issues. Closes: #603510.
  * gdm3.postrm: handle deluser/delgroup failures gracefully.
    Closes: #603753.
  * 29_grep_path.patch: new patch. Don’t hardcode grep to a wrong
    location. Closes: #607664.
  * 30_utf8_locale.patch: new patch. Pass locale.UTF-8 instead of
    locale.utf8. Closes: #607753.

  [ Emilio Pozuelo Monfort ]
  * debian/gdm3.8.pod:
    + Fix typo, thanks Yury V. Zaytsev. Closes: #610723.


gedit (2.30.4-1squeeze1) stable; urgency=low

  * 10_pt_BR_po.patch: fix an important mistake in the Brazilian
    Portuguese translation. Closes: #603502.


git (1:1.7.2.5-1) stable; urgency=low

  * new upstream point release.
    * support "add.ignoreErrors" synonym for the existing
      "add.ignore-errors" configuration variable.
    * bash completion: match lightweight tags in prompt.
    * gitweb: use esc_url to quote a few more URLs.
    * diff: always trim trailing space from --show-c-function lines.
    * some minor test suite and documentation updates.
  * debian/diff/0010-cache_tree_free-Fix-small-memory-leak.diff,
    debian/diff/0011-diff.c-call-regfree....diff,
    debian/diff/0034-gitweb-Introduce-esc_attr...diff: remove; applied
    upstream.
  * add myself as uploader.


gnome-screensaver (2.30.0-2squeeze1) stable; urgency=low

  * Disable libnotify support, the function simply doesn’t work at all.
    Closes: #606830.


gnumed-client (0.7.10-3) stable-proposed-updates; urgency=low

  * Fix regression of last two uploads which did not installed
    translations into correct place
    Closes: #610240


grub-installer (1.60+squeeze2) squeeze; urgency=low

  * Upload to drop .git from source tarball

grub-installer (1.60+squeeze1) stable-proposed-updates; urgency=low

  * Set debconf title to avoid reusing a previous one.


hw-detect (1.84+squeeze2) squeeze; urgency=low

  * No-changes upload to get rid of the .git directory in the source package.

hw-detect (1.84+squeeze1) squeeze; urgency=low

  [ Jurij Smakov ]
  * Increase the number of attempts to detect the new disk devices in
    disk_found() of disk-detect.sh to 15, bringing the total waiting time
    to 28 seconds. Current timeout of 4 seconds is not sufficient for
    some SCSI subsystems with long driver/disk initialization time.
    Closes: #611314

  [ Miguel Figueircedo ]
  * discover-mac-io.sh: Fix module loading for Ibook G4 (powermac). Closes:
    #525902, #525946, #606984.
    Thanks to Risto Suominen <risto.suminen@gmail.com>.

  [ Otavio Salvador ]
  * Blacklist snd-aoa to allow snd-powermac to work. Refs: #606984.


ia32-libs (20110310) stable; urgency=low

  * Packages updated
  * Add fix for duplicate sources due to security updates.
  * Welcome Thijs Kinkhorst to the team.

  [ avahi (0.6.27-2+squeeze1) stable-security; urgency=high ]

  * debian/patches/03_read_null_udp_packets.patch
    - Read NULL UDP packets else we end up in an infinite loop using 100% CPU
      and DoS of Avahi. (#614785, Fixes: CVE-2011-1002)
  * Urgency high for the security fix.

  [ openssl (0.9.8o-4squeeze1) stable-security; urgency=low ]

  * Fix OCSP stapling parse error (CVE-2011-0014)

  [ util-linux (2.17.2-9) unstable; urgency=low ]

  * Ack NMU from Christian Perrier <bubulle@debian.org>
    - Fix encoding for Danish and Slovak debconf translations

  [Adriano Rafael Gomes]

  * Brazilian Portuguese debconf templates translation.  #610489

  [ util-linux (2.17.2-8) unstable; urgency=low ]

  * fix mangled characters in debconf translations

  [ util-linux (2.17.2-7) unstable; urgency=low ]

  * dh_installdebconf is needed in binary-arch, not so much in -indep.
    Based on report from Adam D. Barratt <adam@adam-barratt.org.uk>.
    #566072

  [ util-linux (2.17.2-6) unstable; urgency=low ]

  [Bjørn Steensrud]

  * nb translations.  #608325

  [Américo Monteiro]

  * Portuguese debconf translations. #608233

  [Vincenzo Campanella]

  * Italian translations.  #608307

  [Yuri Kozlov]

  * russian debconf translations.  #608302

  [Martin Ã…gren]

  * Swedish debconf translations.  #608483

  [Joe Dalton]

  * Danish translations.  #608330

  [Christian Perrier]

  * French debconf translations.  #608464

  [Martin Eberhard Schauer]

  * German debconf translations.  #608463

  [Camaleón]

  * Spanish debconf translations.  #608518

  [Thorsten Glaser]

  * hwclock: [m68k] unbreak FTBFS with recent (>= 2.4.18?) kernels.
    #578168

  [Slavko]

  * Slovak transtions.  #608305

  [Michal Simunek]

  * Czech debconf translations.  #608495


ia32-libs-core (20110202) stable; urgency=low

  [ Goswin von Brederlow ]
  * Do not disable secure APT when downloading packages.
  * Add fix for duplicate sources due to security updates.
  * Add security repository next to the regular Debian mirror.
  * Welcome Thijs Kinkhorst to the team.

  * Packages updated

  [ eglibc (2.11.2-10) unstable; urgency=low ]

  * Add patches/amd64/cvs-avx-tcb-alignment.diff from upstream to fix
    alignement issues on CPU supporting the AVX instruction set.
    #610657.

  [ eglibc (2.11.2-9) unstable; urgency=low ]

  * Disable build failure in case of testsuite regressions, will be
    re-enabled after squeeze release.

  [ eglibc (2.11.2-8) unstable; urgency=low ]

  [ Clint Adams ]
  * Japanese debconf translation update from Nobuhiro Iwamatsu.
    #604752.

  [ Samuel Thibault ]
  * Add expected gettext failure on hurd-i386.

  [ Aurelien Jarno ]
  * Update patches/localedata/locale-et_EE.diff to switch Estonian currency
    to euro. #608803.
  * Revert incorrect upstream patch for CVE-2010-3847 and use the correct
    set of patches:
    - Remove patches/any/submitted-origin.diff
    - Add patches/any/cvs-dont-expand-dst-twice.diff
    - Add debian/patches/any/cvs-ignore-origin-privileged.diff
    - Keep debian/patches/any/cvs-audit-suid.diff

  [ ncurses (5.7+20100313-5) unstable; urgency=low ]

  * New patch 01-debian-kfreebsd-terminfo.patch, adding a cons25-debian
    terminfo entry to ncurses-base for the Debian GNU/kfreebsd console
    (#607662).


ia32-libs-gtk (20110310) stable; urgency=low

  * Packages updated
  * Add fix for duplicate sources due to security updates.
  * Welcome Thijs Kinkhorst to the team.

  [ pango1.0 (1.28.3-1+squeeze2) stable-security; urgency=high ]

  * 02_CVE-2011-0064.patch: patch from Behdad Esfahbod and Karl
    Tomlinson to fix buffer overwrite on OOM realloc failure.
    CVE-2011-0064, Mozilla #606997.

  [ pango1.0 (1.28.3-1+squeeze1) unstable; urgency=low ]

  * 01_CVE-2011-0020.patch: patch from Behdad Esfahbod to fix heap
    corruption. #610792, CVE-2011-0020. LP: #696616.


iceape (2.0.11-3) stable-security; urgency=low

  * Fixes for mfsa2011-{01-08,10}, also known as
    CVE-2011-0053, CVE-2011-0051, CVE-2011-0055, CVE-2011-0054,
    CVE-2011-0056, CVE-2011-0057, CVE-2011-0058, CVE-2010-1585,
    CVE-2011-0059.


icedove (3.0.11-1+squeeze1) stable-security; urgency=high

  * [2bf1366] backported patches from xulrunner fixes mfsa2011-{01-08,10}
    - MFSA 2011-01 aka CVE-2011-0053: Miscellaneous memory safety hazards
      (rv:1.9.2.14/ 1.9.1.17)
    - MFSA 2011-02 aka CVE-2011-0051: Recursive eval call causes confirm
      dialogs to evaluate to true
    - MFSA 2011-03 aka CVE-2011-0055: Use-after-free error in JSON.stringify
    - MFSA 2011-04 aka CVE-2011-0054: Buffer overflow in JavaScript upvarMap
    - MFSA 2011-05 aka CVE-2011-0056: Buffer overflow in JavaScript atom map
    - MFSA 2011-06 aka CVE-2011-0057: Use-after-free error using Web Workers
    - MFSA 2011-07 aka CVE-2011-0058: Memory corruption during text run
      construction (Windows)
    - MFSA 2011-08 aka CVE-2010-1585: ParanoidFragmentSink allows javascript:
      URLs in chrome documents
    - MFSA 2011-10 aka CVE-2011-0059: CSRF risk with plugins and 307 redirects


iceweasel (3.5.16-5) stable-security; urgency=low

  * Fixes for mfsa2011-{01-08,10}, also known as
    CVE-2011-0053, CVE-2011-0051, CVE-2011-0055, CVE-2011-0054,
    CVE-2011-0056, CVE-2011-0057, CVE-2011-0058, CVE-2010-1585,
    CVE-2011-0059.


installation-guide (20110122~squeeze1) stable; urgency=low

  * Upload to Squeeze.


isc-dhcp (4.1.1-P1-15+squeeze1) stable-security; urgency=high

  * Non-maintainer upload.
  * Fix cve-2011-0413: remote ipv6 denial-of-service (daemon crash).


katoob (0.5.9.1-1.2+squeeze1) stable; urgency=low

  * Added fix_tooltip_crash.patch (Closes: #611623)


kde4libs (4:4.4.5-2+squeeze1) stable-proposed-updates; urgency=low

  * Add a kconf_update script (migrate_from_kde3_icon_theme) to migrate away
    from old KDE 3 icon themes which are KDE 4 incompatible (e.g. crystalsvg).
    (Closes: #588374)


kdebase-workspace (4:4.4.5-7+squeeze1) stable-proposed-updates; urgency=low

  * Backport 33_backport_krunner_crash_fix_threading.diff patch from 4.5.0 to
    fix random but common krunner crashes. (Closes: #607974)


kernel-wedge (2.74+squeeze2) stable-proposed-updates; urgency=low

  [ Miguel Figueiredo ]
  * mmc-modules: sdhci_pci. Closes: #558036.
  * Add support for Cherry keyboards (hid-cherry on input-modules).
    Closes: #584973.

  [ Joey Hess ]
  * build-arch: Pass -I to dpkg-buildpackage without arguments to take
    advantage of its built-in list of all version control gunk to ignore.

  [ Otavio Salvador ]
  * Use 2.74+squeeze2 version since squeeze1 has been upload to
    unstable by mistake.

kernel-wedge (2.74+squeeze1) unstable; urgency=low

  [ Miguel Figueiredo ]
  * mmc-modules: sdhci_pci. Closes: #558036.
  * Add support for Cherry keyboards (hid-cherry on input-modules).
    Closes: #584973.

  [ Joey Hess ]
  * build-arch: Pass -I to dpkg-buildpackage without arguments to take
    advantage of its built-in list of all version control gunk to ignore.

kernel-wedge (2.74) unstable; urgency=low

  [ Miguel Figueiredo ]
  * usb-modules: xhci module (usb3 support). Closes #601249.
  * nic-wireless-modules: added ralink wireless drivers, thanks to Mike
    Miller. Closes: #604176.
  * mmc-modules: sdhci_pci. Closes: #558036.
  * Add support for Cherry keyboards (hid-cherry on input-modules).
    Closes: #584973.

  [ Joey Hess ]
  * build-arch: Pass -I to dpkg-buildpackage without arguments to take
    advantage of its built-in list of all version control gunk to ignore.

  [ Otavio Salvador ]
  * nic-pcmcia-modules: make netwave_cs and wavelan_cs optional
  * crypto-modules: replace twofish with twofish_generic
  * nic-wireless-modules: replace orinoco_pci with hostap_pci
  * pcmcia-storage-modules: make ide-cs optional
  * serial-modules: add synclink_cs
  * nic-extra-modules: add 3c359
  * ppp-modules: depends on crc-modules
  * scsi-modules: make qla1280 optional


kfreebsd-8 (8.1+dfsg-8) stable-proposed-updates; urgency=low

  [ Petr Salinger ]
  * Add 000_tcp_usrreq.diff, fixes local DoS. Closes: #611476.
  * Extend 108_teken_utf8_table.diff for middle-dot l/L.
    Closes: #609681. Thanks to Robert Millan.


kgb-bot (1.05-1+squeeze1) stable; urgency=low

  [ gregor herrmann ]
  * kgb-bot:
    - fix typo when accessing global config
    - call polygen_available with full class name

  [ Damyan Ivanov ]
  * rules: fix the check whether package version matches "upstream" code
    version. Avoids FTBFS when the package revisiion contains non-digits (e.g.
    stable/security updates). Thanks to Moritz Muehlenhoff. Closes: #612922


krusader (1:2.2.0~beta1-2+squeeze1) stable-proposed-updates; urgency=low

  * Replace rev1154581.patch with backport_fix_krusader_not_terminating.diff
    backported from upstream svn. It has a proper fix for #587842.
    (Closes: #604196)


libapache-mod-jk (1:1.2.30-1squeeze1) stable; urgency=medium

  * Team upload.
  * Fix issue with socket(2) syscall and SOCK_CLOEXEC flag affecting
    upgrades from 1.2.26 to 1.2.30. (Closes: #609886).


libdebian-installer (0.77+squeeze2) squeeze; urgency=low

  * Upload to drop .git from source tarball

libdebian-installer (0.77+squeeze1) squeeze; urgency=low

  [ Martin Michlmayr ]
  * Add support for Buffalo Linkstation LiveV3 (LS-CHL).  Closes: #612168
  * Add support for Buffalo Linkstation Mini (LS-WSGL).


libemail-mime-createhtml-perl (1.029-2) stable; urgency=low

  * Team upload
  * Add libfile-policy-perl as a runtime dependency (Closes: #612003)


libvirt (0.8.3-5+squeeze0) stable; urgency=low

  [ Laurent Léonard ]
  * [6f95d48] Fix exit status codes in libvirt init script to comply with LSB
    (Closes: #612305)


linux-2.6 (2.6.32-31) stable; urgency=low

  [ Ian Campbell ]
  * xen: blkback: fix potential leak of kernel thread. (CVE-2010-3699)

  [ Moritz Muehlenhoff ]
  * rds: Fix rds_iovec page count overflow (CVE-2010-3865)

  [ Ben Hutchings ]
  * tty: Fix information leaks from SIOCGICOUNT handlers (CVE-2010-4075,
    CVE-2010-4076, CVE-2010-4077)
  * bonding: Ensure that we unshare skbs prior to calling pskb_may_pull
    (Closes: #610838)
  * r8169: Keep firmware in memory (Closes: #609538)
  * linux-base: Convert LILO entries for /boot/vmlinuz, /boot/vmlinuz.old
    (Closes: #613200)
  * aufs: Fix VM race leading to kernel panic (Closes: #607879)
  * rt2500usb: Fall back to SW encryption for TKIP+AES (Closes: #611390)
  * Add longterm 2.6.32.29:
    - SCSI: Fix medium error problems with some arrays which can cause
      data corruption
    - ptrace: Use safer wake up on ptrace_detach()
    - [x86] mm: Avoid possible bogus TLB entries by clearing prev
      mm_cpumask after switching mm
    - sched: Fix softirq time accounting
    - sched: Use group weight, idle cpu metrics to fix imbalances during
      idle
    - [openvz,vserver] Revert sched changes since they conflict
  * Revert "USB: Prevent buggy hubs from crashing the USB stack", included
    in longterm 2.6.32.29 and reported to cause a regression
  * virtio_net: Further fixes for out-of-memory conditions (Closes: #603835)
    - Fix OOM handling on TX
    - Add schedule check to napi_enable call
  * af_unix: Limit recursion level of passing sockets through sockets
    (variant of CVE-2010-4249)
  * iowarrior: Don't trust report_size for buffer size (CVE-2010-4656)
  * drm: Fix unsigned vs signed comparison issue in modeset ctl ioctl
    (CVE-2011-1013)
  * brcm80211: Fix suspend/resume in brcmsmac (Closes: #600769, #604802)
  * brcm80211: Fix race between scanning and calibration on SMP
    (Closes: 602444)
  * drm/i915: Overlay on gen2 can't address above 1G
  * drm/i915: Fix memory corruption with GM965 and >4GB RAM
  * ipv6: Silence privacy extensions initialization (Closes: #590653)
  * [x86] Enable VT6656, loading firmware from a separate file (requires
    firmware-linux-nonfree 0.28+squeeze1) (Closes: #568454)
  * usbfs: Show correct speed for SuperSpeed USB devices (Closes: #613531)
  * drm/i915: Add pipe A force quirk for some laptops (Closes: #608148)
  * psmouse/elantech: Fix detection and decoding for newer Elantech
    touchpads (Closes: #613335)

  [ dann frazier ]
  * xfs: Fix information leak using stale NFS handle (CVE-2010-2943)
  * CAN: Use inode instead of kernel address for /proc file (CVE-2010-4565)

  [ maximilian attems]
  * Update openvz patch to feoktistov (ipv6, checkpointing, stability,
    ipsec, nfs, ppp, tc, ve). (closes: #607041, #613501, #613170)
  * HID: add support for Acan FG-8100 barcode reader. (closes: #615888)
  * Add longterm 2.6.32.30:
    - nfsd: Memory corruption due to writing beyond the stat array
    - av7110: check for negative array offset (CVE-2011-0521)
    - cred: Fix get_task_cred() and task_state() to not resurrect dead
      credentials
    - cred: Fix kernel panic upon security_file_alloc() failure
    - cred: Fix BUG() upon security_cred_alloc_blank() failure
    - cred: Fix memory and refcount leaks upon security_prepare_creds()
      failure
    - dm/raid1: Fail writes if errors are not handled and log fails
    - GFS2: Fix bmap allocation corner-case bug
    - [s390] remove task_show_regs (CVE-2011-0710)
    - PM/hibernate: Return error code when alloc_image_page() fails
    - fs/partitions: Validate map_count in Mac partition tables
      (CVE-2011-1010)
    - ALSA: caiaq - Fix possible string-buffer overflow (CVE-2011-0712)
    - acer-wmi, asus_acpi, tc1100-wmi: Restrict write permissions on files
      in procfs/sysfs
    - [x86] usbip/vhci: Update reference count for usb_device
    - [x86] usbip/vhci: Give back URBs from in-flight unlink requests
    - [x86] usbip/vhci: Refuse to enqueue for dead connections
    - epoll: Prevent creating circular epoll structures
    - fs/partitions/ldm: Corrupted partition table can cause kernel oops
    - xhci: Avoid BUG() in interrupt context
    - xhci: Fix errors in the running total calculations in the TRB math
    - xhci: Fix an error in count_sg_trbs_needed()
    - x25: Do not reference freed memory
  * Add longterm 2.6.32.31.
  * Add longterm 2.6.32.32-rc1:
    - netxen: fix set mac addr. (closes: #616058)
    - [xen] do not release any memory under 1M in domain 0. (closes: #613823)
    - virtio: set pci bus master enable bit. (closes: #610360)
    - sctp: Fix oops when sending queued ASCONF chunks (CVE-2010-1173).
    - drm/ttm: Fix two race conditions + fix busy codepaths (closes: #591061)
  * Add Slovak translation by Slavko. (closes: #608684)
  * Add drm changes from 2.6.32.28+drm33.13:
    - drm/i915: Add dependency on CONFIG_TMPFS.
    - drm/i915/lvds: Add AOpen i915GMm-HFS to the list of false-positive LVDS.
    - drm/radeon/kms: add pll debugging output.
    - drm/radeon/kms: add quirk for Mac Radeon HD 2600 card.
    - drm/radeon/kms: fix s/r issues with bios scratch regs.
    - drm/radeon/kms: make the mac rv630 quirk generic.
    - drm/radeon: remove 0x4243 pci id.

  [ Aurelien Jarno ]
  * init: fix race between init and kthreadd, fixes a kernel panic on
    mips/5kc-malta.
  * mips/swarm: enable PATA drivers that have been lost during IDE -> PATA
    conversion.

  [ Martin Michlmayr ]
  * Orion: add support for Buffalo LS-CHL (Closes: #590105).
  * Kirkwood: initialize PCIE1 for QNAP TS-419P+ (Closes: #613499).

  [ Jurij Smakov ]
  * sparc: add sparc-console-handover.patch to address problems with
    console handover on sparc causing kernel to hang during boot on
    systems using atyfb driver.
    Thanks to Fabio M. Di Nitto <fabbione@fabbione.net> for the patch.
    (Closes: #602853)

  [ Bastian Blank ]
  * Add supportt for AMD Family 10h/11h CPU internal temperatur sensor.
    (closes: #614555)


linux-kernel-di-amd64-2.6 (1.76+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-armel-2.6 (1.56+squeeze1) squeeze; urgency=low

  [ Martin Michlmayr ]
  * kirkwood: include ahci in sata-modules since it's needed on the QNAP
    TS-419P+.  Closes: #613497

  [ Otavio Salvador ]
  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-i386-2.6 (1.99+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-ia64-2.6 (1.63+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-mips-2.6 (1.31+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-mipsel-2.6 (1.31+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-powerpc-2.6 (1.76+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-s390-2.6 (0.59+squeeze1) squeeze; urgency=low

  * Built against version 2.6.32-31 of linux-2.6.


linux-kernel-di-sparc-2.6 (1.64+squeeze1) squeeze; urgency=low

  [ Jurij Smakov ]
  [Jurij Smakov]
  * Add niu network driver for sparc, needed by T2+ sparc systems.
    Closes: #608516.

  [ Otavio Salvador ]
  * Built against version 2.6.32-31 of linux-2.6.


logwatch (7.3.6.cvs20090906-1squeeze1) stable-security; urgency=high

  * CVE-2011-1018: Remote code execution by combination of
    - Logfile name by attacker's choice (e.g. samba log files) and
    - Missing sanitization of logfile names in system() call.
    - fix by encapsulating logfile names in ' and disallowing '.
      Taken from upstream.
    - closes: #615995


magpierss (0.72-8+squeeze1) stable-proposed-updates; urgency=low

  * Fixing CVE-2011-0740 (Closes: #611940)

    Cross-site scripting (XSS) vulnerability in
    scripts/magpie_slashbox.php and scripts/simple_smarty.php


mailman (1:2.1.13-5) stable-security; urgency=high

  * Upload to stable to fix security issue.
  * CVE-2011-0707: Cross site scripting in subscriber names.


mcabber (0.10.0-1+squeeze1) squeeze; urgency=medium

  * Pull upstream commit 3695266e16c7 to fix crash after /status invisible
    (closes: #612797)
  * Pull upstream commit e09763e16e49 to fix segfault related to url_regex
    (closes: #612798)
  * Pull upstream commit 75a0a22bbf78 to fix commandline corruption
    (closes: #612789)
  * Pull upstream commit ee8657ff9aa8 to fix two FD leaks
    (closes: #612799)


mediawiki (1:1.15.5-2squeeze1) stable; urgency=high

  * CVE-2011-0047: Protect against a CSS injection vulnerability
    (closes: #611787)


mediawiki-extensions (2.3squeeze1) stable; urgency=low

  * Non-maintainer upload.
  * php53_confirmedit.patch: PHP5.3 compatibility fixes for ConfirmEdit.
    (Closes: #612227)


nautilus (2.30.1-2squeeze1) stable; urgency=low

  * 15_nautilus_file_peek_crash.patch: stolen from upstream git. Fix a
    crasher with lots of upstream duplicates from squeeze systems.


network-manager (0.8.1-6+squeeze1) stable; urgency=low

  * debian/patches/82-core-handle-device-removal.patch
    - Cherry-pick patch from upstream to correctly handle device removal when
      properties are unreadable. (Closes: #605570)
  * debian/patches/83-dnsmasq-send-no-config-file-instead-of-a-bogus-one.patch
    - Newer versions of dnsmasq validate the option parameters more strictly.
      Instead of passing a bogus file name simply use --conf-file without
      additional parameters. (Closes: #615082)
  * debian/ifblacklist_migrate.sh
    - Only comment out iface lines if we have an exact match for the network
      interface. (Closes: #612247)
  * debian/patches/51-normalized-keys.patch
    - Normalize keys in ifupdown parser, so we accept options with either
      hyphens or underscores, like e.g. bridge_ports and bridge-ports.
      (Closes: #609831)


ocrodjvu (0.4.6-3+squeeze1) stable; urgency=low

  * Fix of upside-down generation of hocr data
    [upsidedown-hocr.diff] (closes: #611460).


ocsigen (1.3.3-1squeeze1) stable; urgency=low

  * Add missing dependencies to ocsigen: libocsigen-xhtml-ocaml-dev and
    liblwt-ssl-ocaml-dev (Closes: #613372)


openafs (1.4.12.1+dfsg-4) stable-security; urgency=high

  * Apply upstream deltas:
    - [707a959c] update ticket5 from heimdal.  Avoids a double-free (from
      upstream) which basically allows an arbitrary attack against any
      krb5-aware Rx service by exploiting when the double-free occurs in
      asn1 payloads which came from the wire.
    - [beaf1606] LINUX: Use correct type of error in flock code.  This
      avoids dereferencing a pointer that is not a pointer due to failing
      to properly ERR_PTR a return value.
  * Add a dependency on libc6-dev to openafs-modules-dkms.  dkms doesn't
    depend on it because most kernel modules don't need it, but openafs
    builds userspace helper programs.  Thanks, Peter Palfrader.
    (Closes: #607903)


openssl (0.9.8o-4squeeze1) stable-security; urgency=low

  * Fix OCSP stapling parse error (CVE-2011-0014)


pam-pgsql (0.7.1-4+squeeze1) stable-security; urgency=high

  * add debian/patches/ipaddr-crash_603436.patch: fix crash on long
    addresses that trigger signedness in "%d", thanks to Kees Cook for the
    patch (LP: #722386, Closes: 603436).


pango1.0 (1.28.3-1+squeeze2) stable-security; urgency=high

  * 02_CVE-2011-0064.patch: patch from Behdad Esfahbod and Karl
    Tomlinson to fix buffer overwrite on OOM realloc failure.
    CVE-2011-0064, Mozilla #606997.


partconf (1.36squeeze1) stable-proposed-updates; urgency=low

  [ Aurelien Jarno ]
  * Don't set default debconf values, they are already set in the
    templates. This fixes preseeding.


pdftk (1.41+dfsg-10+squeeze1) stable; urgency=low

  * Support PROMPT for user_pw and owner_pw simultaneously.
    (Closes: #614071)
  * Backport from 1.43: Support filenames starting with the keywords 'odd',
    'even', 'end'. (Closes: #609471)


phpmyadmin (4:3.3.7-5) stable-security; urgency=high

  * Fixes SQL injection (PMASA-2011-2, CVE-2011-0987).


postgresql-8.4 (8.4.7-0squeeze2) stable-security; urgency=high

  * New upstream security/bug fix release:
    - Fix buffer overrun in "contrib/intarray"'s input function for the
      query_int type.
      This bug is a security risk since the function's return address
      could be overwritten. Thanks to Apple Inc's security team for
      reporting this issue and supplying the fix. (CVE-2010-4015)
    - Avoid failures when "EXPLAIN" tries to display a simple-form CASE
      expression.
      If the CASE's test expression was a constant, the planner could
      simplify the CASE into a form that confused the expression-display
      code, resulting in "unexpected CASE WHEN clause" errors.
    - Fix assignment to an array slice that is before the existing range
      of subscripts.
      If there was a gap between the newly added subscripts and the first
      pre-existing subscript, the code miscalculated how many entries
      needed to be copied from the old array's null bitmap, potentially
      leading to data corruption or crash.
    - Avoid unexpected conversion overflow in planner for very distant
      date values.
      The date type supports a wider range of dates than can be
      represented by the timestamp types, but the planner assumed it
      could always convert a date to timestamp with impunity.
    - Fix pg_restore's text output for large objects (BLOBs) when
      standard_conforming_strings is on.
      Although restoring directly to a database worked correctly, string
      escaping was incorrect if pg_restore was asked for SQL text output
      and standard_conforming_strings had been enabled in the source
      database.
    - Fix erroneous parsing of tsquery values containing ... &
      !(subexpression) | ... .
      Queries containing this combination of operators were not executed
      correctly. The same error existed in "contrib/intarray"'s query_int
      type and "contrib/ltree"'s ltxtquery type.
    - Fix bug in "contrib/seg"'s GiST picksplit algorithm.
      This could result in considerable inefficiency, though not actually
      incorrect answers, in a GiST index on a seg column. If you have
      such an index, consider "REINDEX"ing it after installing this
      update. (This is identical to the bug that was fixed in
      "contrib/cube" in the previous update.)

postgresql-8.4 (8.4.6-1) unstable; urgency=low

  * New upstream bug fix release:
    - Force the default wal_sync_method to be fdatasync on Linux.
      The default on Linux has actually been fdatasync for many years,
      but recent kernel changes caused PostgreSQL to choose open_datasync
      instead. This choice did not result in any performance improvement,
      and caused outright failures on certain filesystems, notably ext4
      with the data=journal mount option.
    - Fix assorted bugs in WAL replay logic for GIN indexes.
      This could result in "bad buffer id: 0" failures or corruption of
      index contents during replication.
    - Fix recovery from base backup when the starting checkpoint WAL
      record is not in the same WAL segment as its redo point.
    - Fix persistent slowdown of autovacuum workers when multiple workers
      remain active for a long time.
      The effective vacuum_cost_limit for an autovacuum worker could drop
      to nearly zero if it processed enough tables, causing it to run
      extremely slowly.
    - Add support for detecting register-stack overrun on IA64.
      The IA64 architecture has two hardware stacks. Full prevention of
      stack-overrun failures requires checking both.
    - Add a check for stack overflow in copyObject().
      Certain code paths could crash due to stack overflow given a
      sufficiently complex query.
    - Fix detection of page splits in temporary GiST indexes.
      It is possible to have a "concurrent" page split in a temporary
      index, if for example there is an open cursor scanning the index
      when an insertion is done. GiST failed to detect this case and
      hence could deliver wrong results when execution of the cursor
      continued.
    - Fix error checking during early connection processing.
      The check for too many child processes was skipped in some cases,
      possibly leading to postmaster crash when attempting to add the new
      child process to fixed-size arrays.
    - Improve efficiency of window functions.
      Certain cases where a large number of tuples needed to be read in
      advance, but work_mem was large enough to allow them all to be held
      in memory, were unexpectedly slow. percent_rank(), cume_dist() and
      ntile() in particular were subject to this problem.
    - Avoid memory leakage while "ANALYZE"'ing complex index expressions.
    - Ensure an index that uses a whole-row Var still depends on its
      table.
      An index declared like create index i on t (foo(t.-)) would not
      automatically get dropped when its table was dropped.
    - Do not "inline" a SQL function with multiple OUT parameters.
      This avoids a possible crash due to loss of information about the
      expected result rowtype.
    - Behave correctly if ORDER BY, LIMIT, FOR UPDATE, or WITH is
      attached to the VALUES part of INSERT ... VALUES.
    - Fix constant-folding of COALESCE() expressions.
      The planner would sometimes attempt to evaluate sub-expressions
      that in fact could never be reached, possibly leading to unexpected
      errors.
    - Fix postmaster crash when connection acceptance (accept() or one of
      the calls made immediately after it) fails, and the postmaster was
      compiled with GSSAPI support.
    - Fix missed unlink of temporary files when log_temp_files is active.
      If an error occurred while attempting to emit the log message, the
      unlink was not done, resulting in accumulation of temp files.
    - Add print functionality for InhRelation nodes.
      This avoids a failure when debug_print_parse is enabled and certain
      types of query are executed.
    - Fix incorrect calculation of distance from a point to a horizontal
      line segment.
      This bug affected several different geometric distance-measurement
      operators.
    - Fix incorrect calculation of transaction status in ecpg.
    - Fix PL/pgSQL's handling of "simple" expressions to not fail in
      recursion or error-recovery cases.
    - Fix PL/Python's handling of set-returning functions.
      Attempts to call SPI functions within the iterator generating a set
      result would fail.
    - Fix bug in "contrib/cube"'s GiST picksplit algorithm.
      This could result in considerable inefficiency, though not actually
      incorrect answers, in a GiST index on a cube column. If you have
      such an index, consider "REINDEX"ing it after installing this
      update.
    - Don't emit "identifier will be truncated" notices in
      "contrib/dblink" except when creating new connections.
    - Fix potential coredump on missing public key in "contrib/pgcrypto".
    - Fix memory leak in "contrib/xml2"'s XPath query functions.

postgresql-8.4 (8.4.5-2) unstable; urgency=low

  * debian/control: Build against libedit instead of libreadline. We can't
    simultaneously link against readline (GPL) and libssl (incompatible with
    GPL). (Closes: #603598)

postgresql-8.4 (8.4.5-1) unstable; urgency=medium

  * Urgency medium, since this fixes a security bug (but also a lot of other
    bugs, it's not a pinpointed patch).
  * New upstream security/bug fix update:
    - Use a separate interpreter for each calling SQL userid in PL/Perl
      and PL/Tcl.
      This change prevents security problems that can be caused by
      subverting Perl or Tcl code that will be executed later in the same
      session under another SQL user identity (for example, within a
      SECURITY DEFINER function). Most scripting languages offer numerous
      ways that that might be done, such as redefining standard functions
      or operators called by the target function. Without this change,
      any SQL user with Perl or Tcl language usage rights can do
      essentially anything with the SQL privileges of the target
      function's owner.
      The cost of this change is that intentional communication among
      Perl and Tcl functions becomes more difficult. To provide an escape
      hatch, PL/PerlU and PL/TclU functions continue to use only one
      interpreter per session. This is not considered a security issue
      since all such functions execute at the trust level of a database
      superuser already.
      It is likely that third-party procedural languages that claim to
      offer trusted execution have similar security issues. We advise
      contacting the authors of any PL you are depending on for
      security-critical purposes.
      Our thanks to Tim Bunce for pointing out this issue
      (CVE-2010-3433).
    - Prevent possible crashes in pg_get_expr() by disallowing it from
      being called with an argument that is not one of the system catalog
      columns it's intended to be used with.
    - Fix incorrect placement of placeholder evaluation.
      This bug could result in query outputs being non-null when they
      should be null, in cases where the inner side of an outer join is a
      sub-select with non-strict expressions in its output list.
    - Fix possible duplicate scans of UNION ALL member relations.
    - Fix "cannot handle unplanned sub-select" error.
      This occurred when a sub-select contains a join alias reference
      that expands into an expression containing another sub-select.
    - Fix mishandling of whole-row Vars that reference a view or
      sub-select and appear within a nested sub-select.
    - Fix mishandling of cross-type IN comparisons.
      This could result in failures if the planner tried to implement an
      IN join with a sort-then-unique-then-plain-join plan.
    - Fix computation of "ANALYZE" statistics for tsvector columns.
      The original coding could produce incorrect statistics, leading to
      poor plan choices later.
    - Improve planner's estimate of memory used by array_agg(),
      string_agg(), and similar aggregate functions.
      The previous drastic underestimate could lead to out-of-memory
      failures due to inappropriate choice of a hash-aggregation plan.
    - Fix failure to mark cached plans as transient.
      If a plan is prepared while "CREATE INDEX CONCURRENTLY" is in
      progress for one of the referenced tables, it is supposed to be
      re-planned once the index is ready for use. This was not happening
      reliably.
    - Reduce PANIC to ERROR in some occasionally-reported btree failure
      cases, and provide additional detail in the resulting error
      messages.
      This should improve the system's robustness with corrupted indexes.
    - Fix incorrect search logic for partial-match queries with GIN
      indexes.
      Cases involving AND/OR combination of several GIN index conditions
      didn't always give the right answer, and were sometimes much slower
      than necessary.
    - Prevent show_session_authorization() from crashing within
      autovacuum processes.
    - Defend against functions returning setof record where not all the
      returned rows are actually of the same rowtype.
    - Fix possible corruption of pending trigger event lists during
      subtransaction rollback.
      This could lead to a crash or incorrect firing of triggers.
    - Fix possible failure when hashing a pass-by-reference function
      result.
    - Improve merge join's handling of NULLs in the join columns.
      A merge join can now stop entirely upon reaching the first NULL, if
      the sort order is such that NULLs sort high.
    - Take care to fsync the contents of lockfiles (both "postmaster.pid"
      and the socket lockfile) while writing them.
      This omission could result in corrupted lockfile contents if the
      machine crashes shortly after postmaster start. That could in turn
      prevent subsequent attempts to start the postmaster from
      succeeding, until the lockfile is manually removed.
    - Avoid recursion while assigning XIDs to heavily-nested
      subtransactions.
      The original coding could result in a crash if there was limited
      stack space.
    - Avoid holding open old WAL segments in the walwriter process.
      The previous coding would prevent removal of no-longer-needed
      segments.
    - Fix log_line_prefix's %i escape, which could produce junk early in
      backend startup.
    - Prevent misinterpretation of partially-specified relation options
      for TOAST tables.
      In particular, fillfactor would be read as zero if any other
      reloption had been set for the table, leading to serious bloat.
    - Fix inheritance count tracking in "ALTER TABLE ... ADD CONSTRAINT"
    - Fix possible data corruption in "ALTER TABLE ... SET TABLESPACE"
      when archiving is enabled.
    - Allow "CREATE DATABASE" and "ALTER DATABASE ... SET TABLESPACE" to
      be interrupted by query-cancel.
    - Improve "CREATE INDEX"'s checking of whether proposed index
      expressions are immutable.
    - Fix "REASSIGN OWNED" to handle operator classes and families.
    - Fix possible core dump when comparing two empty tsquery values.
    - Fix LIKE's handling of patterns containing % followed by _.
      We've fixed this before, but there were still some
      incorrectly-handled cases.
    - Re-allow input of Julian dates prior to 0001-01-01 AD.
      Input such as 'J100000'::date worked before 8.4, but was
      unintentionally broken by added error-checking.
    - Fix PL/pgSQL to throw an error, not crash, if a cursor is closed
      within a FOR loop that is iterating over that cursor.
    - In PL/Python, defend against null pointer results from
      PyCObject_AsVoidPtr and PyCObject_FromVoidPtr.
    - In libpq, fix full SSL certificate verification for the case where
      both host and hostaddr are specified.
    - Make psql recognize "DISCARD ALL" as a command that should not be
      encased in a transaction block in autocommit-off mode.
    - Fix some issues in pg_dump's handling of SQL/MED objects.
      Notably, pg_dump would always fail if run by a non-superuser, which
      was not intended.
    - Improve pg_dump and pg_restore's handling of non-seekable archive
      files.
      This is important for proper functioning of parallel restore.
    - Improve parallel pg_restore's ability to cope with selective
      restore (-L option).
      The original code tended to fail if the -L file commanded a
      non-default restore ordering.
    - Fix ecpg to process data from RETURNING clauses correctly.
    - Fix some memory leaks in ecpg.
    - Improve "contrib/dblink"'s handling of tables containing dropped
      columns.
    - Fix connection leak after "duplicate connection name" errors in
      "contrib/dblink".
    - Fix "contrib/dblink" to handle connection names longer than 62
      bytes correctly.
    - Add hstore(text, text) function to "contrib/hstore".
      This function is the recommended substitute for the now-deprecated
      => operator. It was back-patched so that future-proofed code can be
      used with older server versions. Note that the patch will be
      effective only after "contrib/hstore" is installed or reinstalled
      in a particular database. Users might prefer to execute the "CREATE
      FUNCTION" command by hand, instead.
    - Update build infrastructure and documentation to reflect the source
      code repository's move from CVS to Git.
  * debian/postgresql-8.4.preinst: Add missing debhelper token.
  * debian/control: Bump Standards-Version to 3.9.1 (no changes necessary).


proftpd-dfsg (1.3.3a-6squeeze1) stable-security; urgency=high

  * [SECURITY] CVE-2011-1137: mod_sftp behaves badly when receiving badly
    formed SSH messages. See http://bugs.proftpd.org/show_bug.cgi?id=3586


pulseaudio (0.9.21-3+squeeze1) stable; urgency=low

  * Team upload.
  * Fix pacmd hanging in poll() when reading from stdin very early.
    Patch extracted from upstream by Alexander Wuerstlein <arw@arw.name>
   (Closes: #574589)

pulseaudio (0.9.21-3squeeze1) stable; urgency=low

  * Team upload.
  * Fix pacmd hanging in poll() when reading from stdin very early.
    Patch extracted from upstream by Alexander Wuerstlein <arw@arw.name>
   (Closes: #574589)


python-defaults (2.6.6-3+squeeze6) stable; urgency=low

  * pycompile: use /usr/bin/pythonX.Y rather than pythonX.Y (to avoid
    /usr/local interpreters and thus fix some Lenny → Squeeze upgrades)


python-django (1.2.3-3+squeeze1) stable-security; urgency=high

  * Resolve two vulnerabilities:

    - Flaw in CSRF handling

      Django includes a cross-site request forgery protection mechanism, which
      makes use of a token inserted into outgoing forms. Middleware then checks
      for the token's presence on form submission, and validates it.

      Previously, however, Django's CSRF protection made an exception for AJAX
      requests, on the following basis:

      1. Many AJAX toolkits add an 'X-Requested-With' header when using
         XMLHttpRequest.

      2. Browsers have strict same-origin policies regarding XMLHttpRequest.

      3. In the context of a browser, the only way that a custom header of this
         nature can be added is with XMLHttpRequest.

      Therefore, for ease of use, Django did not apply CSRF checks to requests
      that appeared to be AJAX on the basis of the X-Requested-With header. The
      Ruby on Rails web framework had a similar exemption.

      Recently, engineers at Google made members of the Ruby on Rails
      development team aware of a combination of browser plugins and redirects
      which can allow an attacker to provide custom HTTP headers on a request
      to any website. This can allow a forged request to appear to be an AJAX
      request, thereby defeating CSRF protection which trusts the same-origin
      nature of AJAX requests.

      Michael Koziarski of the Rails team brought this to the Django
      developers attention, and we were able to produce a proof-of-concept
      demonstrating the same vulnerability in Django's CSRF handling.

      To remedy this, Django will now apply full CSRF validation to all
      requests, regardless of apparent AJAX origin. This is technically
      backwards-incompatible, but the security risks have been judged to
      outweigh the compatibility concerns in this case.

      Extended notes on how to accomodate this change will be added to the
      Django homepage in following days.

    - Potential XSS in file field rendering

      Django's form system includes form fields and widgets for performing file
      uploads; in many cases, the name of the file currently stored in the
      field is displayed. In the process of rendering, the filename is
      displayed without being escaped.

      In many cases this does not result in a cross-site-scripting
      vulnerability, as file-storage backends can and are encouraged to (and
      the default backends provided with Django do) sanitize the supplied
      filename according to their requirements. However, the risk of a
      vulnerability appearing in a backend which does not sanitize, or which
      performs insufficient sanitization, is such that Django will now
      automatically escape filenames in form rendering.

   Thanks to James Bennett <james@b-list.org>.


pywebdav (0.9.4-1+squeeze1) stable-security; urgency=high

  * Applying CVE-2011-0432.patch for
    MySQL injection possibility in MySQLAuthHandler
    found by Teeed <op.pl> filed under CVE-2011-0432


samba (2:3.5.6~dfsg-3squeeze2) stable-security; urgency=high

  * Security update, fixing the following issue:
    - CVE-2011-0719: denial of service by memory corruption

samba (2:3.5.6~dfsg-3squeeze1) stable-proposed-updates; urgency=low

  * Fix pam_winbind file descriptor leak with a patch
    proposed in https://bugzilla.samba.org/show_bug.cgi?id=7265.
    Upstream claim is that #7265 is fixed in 3.5.6 but our bug submitter
    confirmed it is not while the patch applied here fixes the file
    descriptor leak.
    Closes: #574468

  [ Debconf translations ]
  * Brazilian Portuguese (Adriano Rafael Gomes).  Closes: #607402


shadow (1:4.1.4.2+svn3283-2+squeeze1) stable-security; urgency=high

  * The "Tomanoix" release.
  * debian/patches/300_CVE-2011-0721: Fix insufficient input sanitation
    leading to possible user or group creation in NIS environments.


sobby (0.4.7-2+squeeze1) squeeze; urgency=low

  * The init script creates a new session file if it does not exist yet.
    Add a chown call to make it writeable by sobby, which is not run
    as root.  Make sure to chown the file before sobby's stopped, in
    prerm, so that the write on termination has a chance to succeed.
    (Closes: #613085)


sudo (1.7.4p4-2.squeeze.2) stable; urgency=low

  * patch from upstream to resolve interoperability problem between HOME in
    env_keep and the -H flag, originally closed #596493, applying this to
    to squeeze also closes: #614232


sun-java6 (6.24-1~squeeze1) stable; urgency=low

  * Upload to stable. (Closes: #613723)

sun-java6 (6.23-1) unstable; urgency=low

  * New upstream release
  * Add 'google-chrome' as Depends of sun-java6-plugin (Closes: #607455)
  * Standards-Version updated to version 3.9.1


telepathy-gabble (0.9.15-1+squeeze1) stable-security; urgency=high

  * debian/patches/00-jingleinfo.diff: Added to ignore google:jingleinfo
    pushes from contacts which may theoretically allow an attacker to
    trick Gabble into relaying streamed media through a server of the
    attacker's choosing, enabling them to intercept, obstruct or modify
    the user's audio and video calls.


tomcat6 (6.0.28-9+squeeze1) stable-security; urgency=high

  * Team upload.
  * Update Vcs-* fields in debian/control to track security branch.
  * Add patches for CVE-2011-0534, CVE-2010-3718, CVE-2011-0013
    Thanks to Moritz Muehlenhoff (Closes: #612257)


ttf-liberation (1.05.2.20091019-4squeeze1) stable-proposed-updates; urgency=low

  * Apply a patch by Cody Boisclair backported from upstream git that fixes
    the character widths in Liberation Mono so that it is correctly detected as
    monospaced (rhbz 620273, Closes: #567806).
  * Add myself to Uploaders.


tzdata (2011c-0squeeze1) stable; urgency=low

  * New upstream release.
    - Contains Chilean DST change.  closes: #617331.

tzdata (2011b-2) unstable; urgency=low

  * Mark tzdata and tzdata-java as Multi-Arch: foreign.
    closes: #612700.

tzdata (2011b-1) unstable; urgency=low

  * New upstream release.

tzdata (2011a-1) unstable; urgency=low

  * New upstream release.


usb-modeswitch-data (20100826-1+squeeze0) stable; urgency=low

  * From upstream release 20101222

  * debian/patches/00_squeeze_new_devices.patch:
    + Add new devices
     [0421:0622] Nokia CS-17
     [0421:0627] Nokia CS-18
     [05c7:1000] Qtronix EVDO 3G Modem (for TianYi)
     [0e8d:7109] MediaTek Wimax USB Card
     [0fd1:1000] GW D301 (Advinne AMC)
     [1004:6190] LG AD600
     [106c:3b05] Pantech / UTStarcom UMW190 (Verizon)
     [12d1:1553] Huawei E1553
     [12d1:1c0b] Huawei E173s
     [16d8:6281] C-motech CHU-628S
     [1edf:6003] AirPlus MCD-800
     [230d:0001] Linktop LW272/LW273 (BSNL Teracom)
  * debian/patches/00_squeeze_enlarge_detection_base.patch:
    × Enlarge devices detection base
     [1410:5010] Novatel Wireless devices
     [19d2:2000] ZTE devices
     [1bbb:f000] Alcatel X200/X200L/X060S
  * debian/patches/00_squeeze_huawei_updates.patch:
    × Correct the modeswitching lines for Huawei devices
     [12d1:101e] Huawei U7510 / U7517
     [12d1:1446] Huawei, newer modems
     [12d1:14ad] Vodafone (Huawei) K3806
     [12d1:14c1] Vodafone (Huawei) K4605
     [12d1:1520] Huawei K3765
     [12d1:1521] Huawei K4505
     [12d1:1523] Huawei R201
     [12d1:1557] Huawei E173


why (2.26+dfsg-2+squeeze1) stable; urgency=low

  * Add 0007-Squeeze-s-Coq-is-also-compatible.patch: why-config checks
    compatibility of provers by checking their version number. Coq
    versioned 8.2pl2 is also compatible (like 8.2pl1). Marking it as
    such so that it gets activated.


wordpress (3.0.5+dfsg-0+squeeze1) stable-security; urgency=high

  * [077b77b] Imported Upstream version 3.0.5+dfsg
    - Fixed CVE-2011-0700: two XSS bug. Affects users of the Author or
      Contributor role.
    - Fixed CVE-2011-0701: potential information disclosure of posts through
      the media uploader.


xorg-server (2:1.7.7-13) stable; urgency=low

  * bug script: Report KMS configuration files and their contents.
  * bug script: Keep only one lspci call (with proper filtering), which
    makes PCI IDs come back.
  * Merge from server-1.7-branch, fixing broken rotation with nvidia
    driver (Closes: #611619):
    - Revert "randr: check for virtual size limits before set crtc"
  * bug script: Report libGL-related diversions.

xorg-server (2:1.7.7-12) unstable; urgency=low

  * Cherry-pick this to fix crashes with MCE remotes (Closes: #609750):
    - mi: handle DGA subtypes when determining the master device.
  * Add 22-stop-searching-for-xf86config-files, cherry-picking the
    upstream commit below (which we can't do directly since it depends on
    a patch kept in the quilt series: 08-config-xorg-conf-d.diff), so that
    XF86Config-4 is no longer considered (Closes: #610453). Thanks,
    Bernhard R. Link!
    - Stop searching for XF86Config files
  * Improve bug script:
    - Stop reporting about roster and checksum for config file and server
      symlink, they are no longer used.
    - Replace printf with echo everywhere, it's slightly more readable and
      all lines are newline-terminated anyway.
    - Also use a “pecho” (pretty echo) function to underline some strings,
      making the output slightly more readable.
    - Fix listing xorg.conf.d's contents. Previously, that was only done
      if xorg.conf existed.
    - Check for local libraries by running ldd on the server.
    - Check for obsolete libraries in the same way (/usr/X11R6/lib might
      still exist in some cases, and be referenced in /etc/ld.so.conf, so
      using ldd is sufficient to find out, see #546836 for an example).


xserver-xorg-video-intel (2:2.13.0-6) stable; urgency=low

  * Cherry-pick from upstream:
    - uxa: Fallback if the temporary is too large
  * This fixes a null pointer dereference with some rendering operations
    involving large pictures (Closes: #613830). Thanks, Enrico!
  * Cherry-pick from upstream, thanks to Bjørn Mork:
    - Don't replace the scanout bo through PutImage
    - dri: Fix the use of the uninitialised bo for flink
  * These should fix issues with SDL (Closes: #602207).

=========================================
Sat, 05 Feb 2011 - Debian 6.0 released
=========================================